The Process class relies on proc_open, which is not available on your PHP installation. 解决办法

今天,我用laravel5.6部署服务器的时候,使用composer来安装依赖,出了如下错误:

The Process class relies on proc_open, which is not available on your PHP installation.

中文翻译

Process类依赖于proc_open,这在PHP安装中不可用。

The Process class relies on proc_open, which is not available on your PHP installation.

 

解决办法

只需要在PHP配置文件php.ini中,找到disable_functions选项,看看后面是否有proc_open函数被禁用了,如果有的话,去掉即可。

    A+
发布日期:2018年12月06日 14:56:41  所属分类:Laravel框架
最后更新时间:2018-12-06 14:58:04
标签:
头像
  • ¥ 15元
  • 市场价:15元
  • ¥ 89.0元
  • 市场价:129.0元
  • ¥ 99.0元
  • 市场价:129.0元
  • ¥ 199.0元
  • 市场价:299.0元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:2   其中:访客  0   博主  0

  1. 头像 蔚先森 0

    如果没有呢

    • 付杰 付杰

      @蔚先森 反正原理是这个原理,具体就要看你是用的什么样的集成环境了?例如:宝塔、phpStudy、LNMP……等等,可能每个设置方法会有所不同。有的服务php.ini位置好像有好几个,具体可以去看看!