configure: error: Cannot find php-config. Please use –with-php-config=PATH 解决办法

今天在安装“ pthreads”,直接使用.configure出现了一个错误如下:

configure: error: Cannot find php-config. Please use --with-php-config=PATH

中文翻译如下:

配置:错误:找不到php配置。请使用--使用php路径

 

configure: error: Cannot find php-config. Please use --with-php-config=PATH

 

解决方案:

./configure加上参数--with-php-config,给出正确的php-config路径即可!

命令如下:

./configure --with-php-config=/usr/local/php/bin/php-config

 

上面/usr/local/php/bin/php-config路径请修改成你自己的PHP路径!

    A+
发布日期:2017年09月05日 17:43:18  所属分类:PHP
最后更新时间:2017-09-05 17:44:16
付杰
  • ¥ 1999.9元
  • 市场价:8999元
  • ¥ 39.0元
  • 市场价:39.0元
  • ¥ 999元
  • 市场价:4999元
  • ¥ 999.0元
  • 市场价:1599.0元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: