DL is deprecated, please use Fiddle 解决办法

由于博主最近在windows10电脑上装了一个渗透测试工具PentestBox,直接用“msfconsole”命令启动metasploit时,出现了一个如下警告提示:

DL is deprecated, please use Fiddle

中文翻译

DL已弃用,请使用Fiddle

DL is deprecated, please use Fiddle

 

去掉“DL is deprecated, please use Fiddle”的方法

ruby on rails环境搭建出了此问题也可以用到此方法,因为metasploit就是用ruby开发出来的。

 

1、找到安装目录并进入到:F:\PentestBox\base\ruby\lib\ruby\2.1.0

 

2、将此目录下的dl.rb将里面的warn一行注释掉即可!warn "DL is deprecated, please use Fiddle"

require 'dl.so'

begin
  require 'fiddle' unless Object.const_defined?(:Fiddle)
rescue LoadError
end

#warn "DL is deprecated, please use Fiddle"

module DL
  # Returns true if DL is using Fiddle, the libffi wrapper.
  def self.fiddle?
    Object.const_defined?(:Fiddle)
  end
end

 

3、保存dl.rb,并用命令”msfconsole“重启PentestBox的metasploit。现在已经清静多了,再也没有警告提示信息了。

    A+
发布日期:2019年03月13日 19:54:08  所属分类:PentestBox  Ruby
最后更新时间:2019-03-13 19:56:23
评分: (2 票;平均数5.00 ;最高评分 5 ;用户总数2;总得分 10;百分比100.00)
付杰
服务器管理面板/主机控制面板“安装”服务
服务器管理面板/主机控制面板“安装”服务
  • ¥ 9.9元
  • 市场价:49.9元
SEO顾问服务 中小型网站 单站/最低99.9元 全方位优化
SEO顾问服务 中小型网站 单站/最低99.9元 全方位优化
  • ¥ 99.9元
  • 市场价:5000元
免费SSL证书服务 HTTPS申请 安装 配置 支持通配符*
免费SSL证书服务 HTTPS申请 安装 配置 支持通配符*
  • ¥ 199.9元
  • 市场价:20000元
wp discux 帝国 dedecms phpcms等快速建站
wp discux 帝国 dedecms phpcms等快速建站
  • ¥ 99.9元
  • 市场价:499.9元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: