wordpress升级出现“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限”解决办法

出现“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限”说到底还是权限的问题,如果你是apache的话,权限设置必须要给足够;否则你升级是不能成功的;

 

此文适合所有用wordpress的朋友们!不管你是nginx还是apache;

 

今天在帮朋友安装wordpress的时候,也出现了这样的一个问题,它的服务器环境是:

Centos6.8+Apache2.2.31+MySQL 5.5.48+PHP7.0.7

 

我最初给的权限是这样的:根目录(wwwroot)我给的是755权限,wp-content我给的是777权限;

 

1、第一次升级出现的第一个问题:

“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。:wp-admin/includes/update-core.php 安装失败”;

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。:wp-admin/includes/update-core.php 安装失败

 

解决办法也很简单,直接给update-core.php 777权限;

chmod 777 update-core.php

 

2、继续第二次升级又出现另一个问题:

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-admin/js/updates.min.js, wp-admin/js/common.js, wp-admin/js/customize-controls.js, wp-admin/js/common.min.js, wp-admin/js/updates.js, wp-admin/js/customize-controls.min.js, wp-admin/includes/file.php, wp-admin/customize.php, wp-admin/about.php, wp-includes/js/plupload/handlers.min.js, wp-includes/js/plupload/handlers.js, wp-includes/js/wp-api.js, wp-includes/js/wp-api.min.js, wp-includes/class-wp-customize-manager.php, wp-includes/class-http.php, wp-includes/class-wp-xmlrpc-server.php, wp-includes/version.php, wp-includes/taxonomy.php

安装失败

 

由于未截图,请大家看文字;

 

解决办法同样简单,直接给wp-admin文件及子文件777权限;

chmod -R 777 wp-admin

 

3、继续我的第三次升级,又出现一个问题:

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-includes/js/plupload/handlers.min.js, wp-includes/js/plupload/handlers.js, wp-includes/js/wp-api.js, wp-includes/js/wp-api.min.js, wp-includes/class-wp-customize-manager.php, wp-includes/class-http.php, wp-includes/class-wp-xmlrpc-server.php, wp-includes/version.php, wp-includes/taxonomy.php

安装失败

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。

 

解决办法依然很简单,直接修改wp-includes权限为777;

chmod -R 777 wp-includes

 

4、继续再进行我的最后一次升级wordpress,升级成功!

 

5、如果第4步再次升级没有成功,却出现了如下情况:

正在从http://downloads.wordpress.org/release/zh_CN/wordpress-4.9.4.zip下载更新文件…

正在解压缩升级文件…

正在校验解压的文件…

正在准备安装最新版本…

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-settings.php, wp-cron.php, wp-signup.php, wp-trackback.php, wp-login.php, wp-load.php, wp-activate.php, wp-config-sample.php

安装失败

 

解决办法同样很简单,只需要给 wp-settings.php, wp-cron.php, wp-signup.php, wp-trackback.php, wp-login.php, wp-load.php, wp-activate.php, wp-config-sample.php 同样的权限777,这样就不会出现存在不一致的文件权限的问题;

[[email protected] html]# chmod 777 wp-settings.php
[[email protected] html]# chmod 777 wp-cron.php
[[email protected] html]# chmod 777 wp-signup.php
[[email protected] html]# chmod 777 wp-trackback.php
[[email protected] html]# chmod 777 wp-login.php
[[email protected] html]# chmod 777 wp-load.php
[[email protected] html]# chmod 777 wp-activate.php
[[email protected] html]# chmod 777 wp-config-sample.php

 

6、再一次后台更新我的wordpress, 更新成功!

 

说明:因为我目前来说,很少用lamp环境了,今天也是第一次用lamp环境安装wordpress,由于apache的原因,apache需要的权限和nginx需要的权限是不一样的,因此,如果你需要这种类似的情况,只要是权限不够,缺少什么权限你就给什么权限!如果你实在不懂权限这方面的知识,你直接给777权限;

 

注意:上面这些目录或文件权限修改为了777升级成功了后,一定要再回去把它的权限修改为755;

 

总结:由于wordpress这个程序的问题,它升级的时候讲究的是权限必须是一样的,只要有一些文件权限不一样,就会一直提示“这通常是因为存在不一致的文件权限”这个问题;如果你服务器安装了wordpress后,你又经常改了一些权限的话,到时候后台更新起来是非常麻烦的一件事情!只能把所有的文件或目录权限设置成一样的;

    A+
发布日期:2017年05月21日 17:32:04  所属分类:WordPress
最后更新时间:2018-03-13 17:04:09
评分: (4 票;平均数4.25 ;最高评分 5 ;用户总数4;总得分 17;百分比85.00)
付杰
花牛苹果 甘肃天水 李宏恩家自种 1斤 包邮
花牛苹果 甘肃天水 李宏恩家自种 1斤 包邮
  • ¥ 6.8元
  • 市场价:8.8元
wordpress discux dedecms 帝国 phpcms等快速建站服务
wordpress discux dedecms 帝国 phpcms等快速建站服务
  • ¥ 99.9元
  • 市场价:499.9元
SEO顾问服务 中小型网站 单站/最低99.9元 全方位优化
SEO顾问服务 中小型网站 单站/最低99.9元 全方位优化
  • ¥ 99.9元
  • 市场价:5000元
wordpress站群服务 泛解析二级域名站群 二级目录站群
wordpress站群服务 泛解析二级域名站群 二级目录站群
  • ¥ 1999.9元
  • 市场价:4800元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

 

目前评论:19   其中:访客  13   博主  6

  1. 萧瑟の暧昧 0

    我今天由wordpress4.9.8升级到5.0,也出现类似这样的问题,不过根据博主思路,我也解决了。只需要执行以下命令就可以解决了。升级成功后一定要改成755。

    [[email protected] html]# chmod -R 777  wp-admin/
    [[email protected] html]# chmod -R 777  wp-includes/
    [[email protected] html]# chmod 777 wp-login.php 
    [[email protected] html]# chmod 777 wp-settings.php
  2. 二哥 0

    我今天由wordpress4.9.7升级到4.9.8,也出现类似这样的问题,不过根据博主思路,我也解决了。只需要执行以下命令就可以解决了。升级成功后一定要改成755。

    [[email protected] html]# chmod -R 777 wp-admin
    [[email protected] html]# chmod -R 777 wp-includes
    [[email protected] html]# chmod 777 wp-login.php
  3. EZ飞哥 0

    我也遇到了这个问题,我是由wordpress4.9.6升级到4.9.7,方法更加简单,只需要两行命令就可以解决了。
    升级后权限一定要改为755。

    [[email protected] html]# chmod -R 777 wp-admin
    [[email protected] html]# chmod -R 777 wp-includes
  4. 布衣神相 0

    今天我由wordpress4.9.5升级到4.9.6也出现这个问题,但是解决起来更加的简单;只要在升级前运行以下命令即可!升级后权限一定要改回755;

    [[email protected] html]# chmod -R 777 wp-admin
    [[email protected] html]# chmod -R 777 wp-includes
    
    [[email protected] html]# chmod 777 wp-signup.php
    [[email protected] html]# chmod 777 wp-signup.php
    [[email protected] html]# chmod 777 wp-login.php 
    [[email protected] html]# chmod 777 wp-activate.php 
    [[email protected] html]# chmod 777 wp-comments-post.php
  5. 付杰 付杰

    今天我由wordpress4.9.4升级到4.9.5也出现这个问题,但是解决起来更加的简单;只要在升级前做如下设置即可!升级后权限一定要改回755;

    
    cd /homw/wwwroot/html
    chmod 777 wp-admin/includes/update-core.php
    chmod -R 777 wp-admin
    chmod 777 wp-config-sample.php
    chmod 777 wp-login.php
    chmod 777 wp-activate.php
  6. 北辰一刀流 0

    不知道怎么回事!以前没事,今天wordpress后台自动更新的时候也出现如下错误:

    正在从https://downloads.wordpress.org/release/zh_CN/wordpress-4.9.4.zip下载更新文件…
    
    正在解压缩升级文件…
    
    正在校验解压的文件…
    
    正在准备安装最新版本…
    
    因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-settings.php, wp-cron.php, wp-signup.php, wp-trackback.php, wp-login.php, wp-load.php, wp-includes/rest-api.php, wp-includes/canonical.php, wp-includes/class-wp-image-editor-gd.php, wp-includes/embed.php, wp-includes/class-wp-comment-query.php, wp-includes/class-wp-customize-control.php, wp-includes/class-wp-meta-query.php, wp-includes/class-wp-post-type.php, wp-includes/class-wp-text-diff-renderer-table.php, wp-includes/pluggable.php, wp-includes/class-wp-term.php, wp-includes/class-wp-feed-cache-transient.php, wp-includes/class-wp-role.php, wp-includes/post-formats.php, wp-includes/class-wp-session-tokens.php, wp-includes/class-wp-simplepie-file.php, wp-includes/js/wp-emoji-loader.js, wp-includes/js/media-audiovideo.min.js, wp-includes/js/heartbeat.min.js, wp-includes/js/swfupload/handlers.js, wp-includes/js/swfupload/swfupload.js, wp-includes/js/swfupload/handlers.min.js, wp-includes/js/wp-backbone.js, wp-includes/js/mce-view.min.js, wp-includes/js/customize-loader.js, wp-includes/js/customize-views.js, wp-includes/js/twemoji.js, wp-includes/js/customize-base.min.js, wp-includes/js/heartbeat.js, wp-includes/js/media-grid.js, wp-includes/js/wp-api.js, wp-includes/js/thickbox/thickbox.css, wp-includes/js/customize-preview-widgets.js, wp-includes/js/wp-emoji-loader.min.js, wp-includes/js/customize-preview-widgets.min.js, wp-includes/js/autosave.js, wp-includes/js/media-grid.min.js, wp-includes/js/customize-preview.js, wp-includes/js/twemoji.min.js, wp-includes/js/wp-pointer.js, wp-includes/js/media-audiovideo.js, wp-includes/js/wp-util.js, wp-includes/js/jquery/jquery.form.min.js, wp-includes/js/jquery/jquery.form.js, wp-includes/js/mce-view.js, wp-includes/js/customize-selective-refresh.min.js, wp-includes/js/customize-base.js, wp-includes/js/shortcode.js, wp-includes/js/wp-api.min.js, wp-includes/js/customize-selective-refresh.js, wp-includes/js/media-views.min.js, wp-includes/js/wp-embed.js, wp-includes/js/mediaelement/mediaelement-and-player.min.js, wp-includes/js/mediaelement/mediaelementplayer.min.css, wp-includes/js/mediaelement/wp-playlist.js, wp-includes/js/mediaelement/wp-mediaelement.min.css, wp-includes/js/mediaelement/wp-playlist.min.js, wp-includes/js/mediaelement/wp-mediaelement.js, wp-includes/js/mediaelement/wp-mediaelement.css, wp-includes/js/mediaelement/wp-mediaelement.min.js, wp-includes/js/customize-loader.min.js, wp-includes/js/wp-a11y.js, wp-includes/js/media-views.js, wp-includes/js/tinymce/utils/mctabs.js, wp-includes/js/tinymce/tiny_mce_popup.js, wp-includes/js/tinymce/tinymce.min.js, wp-includes/js/tinymce/themes/inlite/theme.min.js, wp-includes/js/tinymce/themes/inlite/theme.js, wp-includes/js/tinymce/wp-tinymce.js.gz, wp-includes/js/tinymce/skins/lightgray/skin.min.css, wp-includes/js/tinymce/skins/lightgray/content.inline.min.css, wp-includes/js/tinymce/skins/lightgray/content.min.css, wp-includes/js/tinymce/skins/wordpress/wp-content.css, wp-includes/js/tinymce/plugins/paste/plugin.min.js, wp-includes/js/tinymce/plugins/paste/plugin.js, wp-includes/js/tinymce/plugins/image/plugin.min.js, wp-includes/js/tinymce/plugins/image/plugin.js, wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js, wp-includes/js/tinymce/plugins/wpeditimage/plugin.js, wp-includes/js/tinymce/plugins/wplink/plugin.min.js, wp-includes/js/tinymce/plugins/wplink/plugin.js, wp-includes/js/tinymce/plugins/wpview/plugin.min.js, wp-includes/js/tinymce/plugins/wpview/plugin.js, wp-includes/js/tinymce/plugins/wordpress/plugin.min.js, wp-includes/js/tinymce/plugins/wordpress/plugin.js, wp-includes/js/tinymce/plugins/lists/plugin.min.js, wp-includes/js/tinymce/plugins/lists/plugin.js, wp-includes/js/customize-preview-nav-menus.js, wp-includes/js/utils.js, wp-includes/js/wp-custom-header.js, wp-includes/js/plupload/wp-plupload.js, wp-includes/js/comment-reply.js, wp-includes/js/wp-emoji-release.min.js, wp-includes/js/media-models.min.js, wp-includes/js/shortcode.min.js, wp-includes/js/media-editor.js, wp-includes/js/customize-models.js, wp-includes/js/customize-models.min.js, wp-includes/js/customize-preview.min.js, wp-includes/js/media-models.js, wp-includes/class-wp-error.php, wp-includes/class-wp-widget-factory.php, wp-includes/feed.php, wp-includes/class-wp-list-util.php, wp-includes/default-widgets.php, wp-includes/class-wp-comment.php, wp-includes/class-wp-http-requests-response.php, wp-includes/class.wp-dependencies.php, wp-includes/class-wp-editor.php, wp-includes/ms-default-constants.php, wp-includes/class-wp-roles.php, wp-includes/ms-settings.php, wp-includes/class-walker-category-dropdown.php, wp-includes/query.php, wp-includes/class-wp-user-meta-session-tokens.php, wp-includes/customize/class-wp-customize-sidebar-section.php, wp-includes/customize/class-wp-customize-custom-css-setting.php, wp-includes/customize/class-wp-customize-nav-menu-setting.php, wp-includes/customize/class-wp-customize-background-position-control.php, wp-includes/customize/class-wp-customize-media-control.php, wp-includes/customize/class-wp-customize-new-menu-control.php, wp-includes/customize/class-wp-customize-nav-menu-name-control.php, wp-includes/customize/class-wp-customize-color-control.php, wp-includes/customize/class-wp-customize-header-image-control.php, wp-includes/customize/class-wp-customize-nav-menu-auto-add-control.php, wp-includes/customize/class-wp-customize-site-icon-control.php, wp-includes/customize/class-wp-customize-filter-setting.php, wp-includes/customize/class-wp-customize-nav-menu-section.php, wp-includes/customize/class-wp-customize-partial.php, wp-includes/customize/class-wp-customize-new-menu-section.php, wp-includes/customize/class-wp-customize-theme-control.php, wp-includes/customize/class-wp-customize-nav-menu-item-control.php, wp-includes/customize/class-wp-customize-nav-menu-location-control.php, wp-includes/customize/class-wp-widget-form-customize-control.php, wp-includes/customize/class-wp-customize-nav-menus-panel.php, wp-includes/customize/class-wp-customize-selective-refresh.php, wp-includes/customize/class-wp-customize-nav-menu-item-setting.php, wp-includes/customize/class-wp-customize-image-control.php, wp-includes/customize/class-wp-widget-area-customize-control.php, wp-includes/customize/class-wp-customize-themes-section.php, wp-includes/customize/class-wp-customize-cropped-image-control.php, wp-includes/customize/class-wp-customize-nav-menu-control.php, wp-includes/class-walker-page.php, wp-includes/class-wp-site-query.php, wp-includes/nav-menu.php, wp-includes/class.wp-styles.php, wp-includes/rss-functions.php, wp-includes/pomo/po.php, wp-includes/pomo/translations.php, wp-includes/class-walker-comment.php, wp-includes/cache.php, wp-includes/script-loader.php, wp-includes/category-template.php, wp-includes/class-wp-customize-nav-menus.php, wp-includes/comment-template.php, wp-includes/class-wp-widget.php, wp-includes/class-wp.php, wp-includes/rest-api/class-wp-rest-response.php, wp-includes/rest-api/class-wp-rest-server.php, wp-includes/rest-api/fields/class-wp-rest-term-meta-fields.php, wp-includes/rest-api/fields/class-wp-rest-post-meta-fields.php, wp-includes/rest-api/fields/class-wp-rest-user-meta-fields.php, wp-includes/rest-api/fields/class-wp-rest-meta-fields.php, wp-includes/rest-api/fields/class-wp-rest-comment-meta-fields.php, wp-includes/rest-api/class-wp-rest-request.php, wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-comments-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-users-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-revisions-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-post-statuses-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-post-types-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-attachments-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-taxonomies-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-terms-controller.php, wp-includes/rest-api/endpoints/class-wp-rest-settings-controller.php, wp-includes/l10n.php, wp-includes/class-wp-walker.php, wp-includes/class-wp-taxonomy.php, wp-includes/random_compat/random_bytes_libsodium.php, wp-includes/random_compat/random_bytes_com_dotnet.php, wp-includes/random_compat/random_bytes_dev_urandom.php, wp-includes/random_compat/random_int.php, wp-includes/random_compat/random_bytes_libsodium_legacy.php, wp-includes/random_compat/random_bytes_openssl.php, wp-includes/random_compat/random_bytes_mcrypt.php, wp-includes/deprecated.php, wp-includes/class-wp-xmlrpc-server.php, wp-includes/class-wp-theme.php, wp-includes/user.php, wp-includes/link-template.php, wp-includes/class-wp-customize-setting.php, wp-includes/cron.php, wp-includes/theme-compat/embed-content.php, wp-includes/class.wp-scripts.php, wp-includes/general-template.php, wp-includes/kses.php, wp-includes/class-wp-query.php, wp-includes/ms-default-filters.php, wp-includes/class-wp-embed.php, wp-includes/class-wp-feed-cache.php, wp-includes/class-wp-network.php, wp-includes/class-wp-image-editor-imagick.php, wp-includes/widgets/class-wp-widget-text.php, wp-includes/widgets/class-wp-widget-tag-cloud.php, wp-includes/widgets/class-wp-widget-calendar.php, wp-includes/widgets/class-wp-widget-categories.php, wp-includes/widgets/class-wp-widget-recent-posts.php, wp-includes/widgets/class-wp-widget-rss.php, wp-includes/widgets/class-wp-nav-menu-widget.php, wp-includes/widgets/class-wp-widget-archives.php, wp-includes/widgets/class-wp-widget-links.php, wp-includes/widgets/class-wp-widget-recent-comments.php, wp-includes/widgets/class-wp-widget-search.php, wp-includes/widgets/class-wp-widget-pages.php, wp-includes/widgets/class-wp-widget-meta.php, wp-includes/widgets.php, wp-includes/plugin.php, wp-includes/rewrite.php, wp-includes/class-wp-customize-widgets.php, wp-includes/class-wp-dependency.php, wp-includes/class-wp-http-streams.php, wp-includes/class-wp-locale-switcher.php, wp-includes/Text/Diff/Engine/native.php, wp-includes/Text/Diff/Engine/shell.php, wp-includes/class-wp-network-query.php, wp-includes/compat.php, wp-includes/ms-deprecated.php, wp-includes/capabilities.php, wp-includes/nav-menu-template.php, wp-includes/default-constants.php, wp-includes/class-wp-customize-panel.php, wp-includes/class-walker-nav-menu.php, wp-includes/template.php, wp-includes/meta.php, wp-includes/author-template.php, wp-includes/class-wp-simplepie-sanitize-kses.php, wp-includes/class-wp-matchesmapregex.php, wp-includes/class-wp-hook.php, wp-includes/post-template.php, wp-includes/class-wp-image-editor.php, wp-includes/media.php, wp-includes/wp-db.php, wp-includes/registration.php, wp-includes/class-wp-ajax-response.php, wp-includes/class-wp-site.php, wp-includes/css/wp-pointer.min.css, wp-includes/css/editor.min.css, wp-includes/css/editor-rtl.css, wp-includes/css/customize-preview.css, wp-includes/css/media-views-rtl.min.css, wp-includes/css/dashicons.css, wp-includes/css/jquery-ui-dialog-rtl.min.css, wp-includes/css/jquery-ui-dialog-rtl.css, wp-includes/css/wp-embed-template-ie.min.css, wp-includes/css/media-views.css, wp-includes/css/buttons-rtl.min.css, wp-includes/css/wp-pointer-rtl.min.css, wp-includes/css/wp-pointer.css, wp-includes/css/buttons-rtl.css, wp-includes/css/media-views-rtl.css, wp-includes/css/wp-auth-check.css, wp-includes/css/wp-auth-check.min.css, wp-includes/css/jquery-ui-dialog.min.css, wp-includes/css/wp-pointer-rtl.css, wp-includes/css/customize-preview-rtl.min.css, wp-includes/css/wp-embed-template.css, wp-includes/css/jquery-ui-dialog.css, wp-includes/css/dashicons.min.css, wp-includes/css/media-views.min.css, wp-includes/css/customize-preview.min.css, wp-includes/css/wp-auth-check-rtl.css, wp-includes/css/admin-bar.min.css, wp-includes/css/admin-bar.css, wp-includes/css/admin-bar-rtl.min.css, wp-includes/css/wp-embed-template.min.css, wp-includes/css/buttons.min.css, wp-includes/css/customize-preview-rtl.css, wp-includes/css/editor-rtl.min.css, wp-includes/css/admin-bar-rtl.css, wp-includes/css/wp-auth-check-rtl.min.css, wp-includes/css/editor.css, wp-includes/css/buttons.css, wp-includes/class-wp-oembed-controller.php, wp-includes/load.php, wp-includes/class-http.php, wp-includes/class-snoopy.php, wp-includes/class-wp-http-cookie.php, wp-includes/class-wp-locale.php, wp-includes/class-wp-user-query.php, wp-includes/ms-load.php, wp-includes/class-wp-admin-bar.php, wp-includes/class-oembed.php, wp-includes/theme.php, wp-includes/update.php, wp-includes/class-wp-customize-section.php, wp-includes/functions.php, wp-includes/formatting.php, wp-includes/version.php, wp-includes/default-filters.php, wp-includes/class-wp-http-curl.php, wp-includes/ms-blogs.php, wp-includes/class-wp-user.php, wp-includes/admin-bar.php, wp-includes/vars.php, wp-includes/class-wp-metadata-lazyloader.php, wp-includes/class-wp-tax-query.php, wp-includes/post-thumbnail-template.php, wp-includes/http.php, wp-includes/date.php, wp-includes/class-wp-http-response.php, wp-includes/class-walker-page-dropdown.php, wp-includes/comment.php, wp-includes/class-wp-post.php, wp-includes/ms-functions.php, wp-includes/option.php, wp-includes/taxonomy.php, wp-includes/class-wp-rewrite.php, wp-includes/post.php, wp-includes/class-wp-term-query.php, wp-includes/class-walker-category.php, wp-includes/media-template.php, wp-includes/class-wp-customize-manager.php, wp-includes/rss.php, wp-includes/class-wp-http-requests-hooks.php, wp-includes/ID3/module.tag.id3v2.php, wp-includes/ID3/module.audio-video.flv.php, wp-includes/ID3/module.audio-video.asf.php, wp-includes/ID3/getid3.php, wp-includes/ID3/module.audio.mp3.php, wp-includes/ID3/module.audio-video.quicktime.php, wp-includes/ID3/module.audio-video.riff.php, wp-includes/ID3/module.audio.ac3.php, wp-includes/ID3/module.audio-video.matroska.php, wp-includes/ID3/module.audio.ogg.php, wp-includes/ID3/getid3.lib.php, wp-includes/ID3/module.tag.lyrics3.php, wp-includes/ID3/module.tag.apetag.php, wp-includes/ID3/module.tag.id3v1.php, wp-includes/shortcodes.php, wp-activate.php, wp-config-sample.php
    
    安装失败
    • 付杰 付杰

      @北辰一刀流 只要出现类似的错误,建议你直接给权限即可!为了一劳永逸,更新前建议把:wp-admin 、 wp-includes这个目录权限直接给777;命令如下:

      cd /home/wwwroot/html
      chmod -R 777 wp-admin
      chmod -R 777 wp-includes
      

       
      注意:更新完成后,一定要把权限改成755;命令如下:

      cd /home/wwwroot/html
      chmod -R 755 wp-admin
      chmod -R 755 wp-includes
      
  7. 牛耳 0

    我是wordpress后台更新升级的时候,出现下面这个错误怎么办?也是给权限吗?

    正在从https://downloads.wordpress.org/release/zh_CN/wordpress-4.9.4.zip下载更新文件…
    
    正在解压缩升级文件…
    
    
    Warning: copy(/home/wwwroot/html/wp-admin/includes/update-core.php): failed to open stream: Permission denied in /home/wwwroot/html/wp-admin/includes/class-wp-filesystem-direct.php on line 257
    因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-admin/includes/update-core.php
    
    安装失败
    • 付杰 付杰

      @牛耳 只要出现类似的错误,建议你直接给权限即可!为了一劳永逸,更新前建议把:wp-admin\wp-includes这个目录权限直接给777;命令如下:

      cd /home/wwwroot/html
      chmod -R 777 wp-admin
      chmod -R 777 wp-includes
      

       
      注意:更新完成后,一定要把权限改成755;命令如下:

      cd /home/wwwroot/html
      chmod -R 755 wp-admin
      chmod -R 755 wp-includes
      
      • 飞龙 1

        @付杰 我的也出现这个问题,但给了777权限还是不行呢?

        • 飞龙 1

          @飞龙 这是截图,发不上呢

          • 付杰 付杰

            @飞龙 你可以Q上直接联系我!

        • 付杰 付杰

          @飞龙 给了777权限还不行,又报什么错了?你得说明你的具体情况;可以Q上联系我!

  8. 贺岁 1

    今天我也出现”阿里云更新失败:因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致……”的问题!

  9. 菊部 0

    感谢分享 用博主的方法搞定了

  10. PHP新手刚入行一月 1

    权限真是一个很麻烦的事情,还好安装wordpress有提示!

  11. 拉钩子 1

    完美解决了我的问题!

  12. wp专家 2

    安装wp的时候最好看一下要什么权限。