eNSP使用 之 配置“静态路由”教程

—. 实验目的

掌握静态路由协议,理解路由器工作原理,掌握路由器相关的配置、检测操作。

 

二. 实验内容

华为网络设备常用配置命令

华为网络模拟器 eNSP的安装

•IP地址的配置;

•静态路由的配置;

•路由规划;

•网络收敛的概念;

•网络测试与排错操作。

 

三. 实验原理、方法和手段

图 3.1–1实验拓扑图

图 3.1–1实验拓扑图

 

1、用路由器连接若干局域网,局域网之间建议采用Ethernet协议连接,局域网之间采用静态路由,从而使在不同局域网上的计算机能够交换信息。观察联通前后计算机和路由器路由表的变化情况,并给出解释。

2、通过ping其他主机,用 Wireshark捕捉网络流量,找出与 ping相关的ARP协议、ICMP协议报文逐字节地进行剖析(选做)

 

四. 实验条件

•华为 eNSP仿真平台中:2台 PC,三台路由器;

•双绞线若干。

 

五. 实验步骤

实验说明:路由器端口以具体选用的设备为准(如路由器型号为 AR2240以上,端口为千兆以太网口GE0/0/0;如路由器型号为AR201,端口为以太网口E0/0/0),请将 EthernetX口和Y口对应到实际设备上的端口名称,如实际使用的端口名称应为GE0/0/0或E0/0等类似名称。如果是实际设备,请观察路由器前面板和后面板的端口名称,并使用 disp int 或者 disp cur 命令查看端口的实际名称。在对路由器进行配置时,可使用 dispcur命令来检查当前路由器上生效的配置命令。

 

1、硬件连接。完成PC1、PC2到路由器的网络连接;PC1到路由器RT1控制线的连接,PC2到路由器 RT2控制线的连接。拓扑图检查无误后方可进行后面的实验步骤, 实验报告中的拓扑图必须标清路由器实际连接的端口。硬件连接。完成PC1、PC2到路由器的网络连接;PC1到路由器RT1控制线的连接,PC2到路由器 RT2控制线的连接。拓扑图检查无误后方可进行后面的实验步骤, 实验报告中的拓扑图必须标清路由器实际连接的端口。

 

以下这个图是我们实验的拓补图,一个颜色的方块代表一个网段,分别是192.168.1.0、2.0、3.0、4.0. 192.168.1.0/24 代表的IP段就是 192.168.1.1 ~ 192.168.1.254。我们的实验目的就是最终实现从红色方块的PC1 通过静态路由的方式访问到黑色网段内的PC2。

以下这个图是我们实验的拓补图,一个颜色的方块代表一个网段,分别是192.168.1.0、2.0、3.0、4.0. 192.168.1.0/24 代表的IP段就是 192.168.1.1 ~ 192.168.1.254。我们的实验目的就是最终实现从红色方块的PC1 通过静态路由的方式访问到黑色网段内的PC2。

 

2、为 PC1、PC2 分别设置 IP 地址、掩码和网关。

pc1

pc1

 

pc2

pc2

 

3、使用 sysname命令为三个路由器命名。路由器 R1的名称为学生自己的姓名拼音 +R1,路由器R2的名称为学生自己的姓名拼音+R2,路由器 R3的名称为学生自己的姓名拼音+R3,要求记录输入的命令和输出(截屏)。

此答案在R1、R2、R3命令后面,包括截图。

 

4、给R1路由器命名,(从左至右配置)为路由器R1的两个接口配置IP地址。配置完成后PC1应该可以Ping通RT1的E0口的地址。要求记录输入的命令和输出(截屏)。(本模拟器 R1实际使用的接口名由实际使用的路由器型号确定,可能有 Ethernet0/0/0;或 GigabitEthernet0/0/x;或 FastEthernet0/0/x)R1上的命令:

我们这里以R1为例。在R1路由器配置通向PC2网段的静态路由。在静态路由配置之前,要先把路由器的接口ip和子网掩码设置好,这个在上上节课XX老师也跟大家简单提过,首先从用户模式进入系统模式,用sysname将路由器设置成自己的名字,这个名字具体要求报告里面有大家注意一下,接下来用]int g0/0/0进入路由器的g0口,大家要注意不同的路由器使用的接口名是由路由器型号确定,可能有 Ethernet0/0/0;或 GigabitEthernet0/0/x或 FastEthernet0/0/x) 如路由器型号为 AR2240 以上,端口为千兆以太网口 GE0/0/0;如路由器型号为 AR201,端口为以太网口 E0/0/0)

在eNSP里也可以设置,显示所有接口,这样会把路由器的所有接口显示出来,就不会出错了。然后配置ip地址,配置ip地址的原则就是ip address+ip地址+子网掩码,g0口配置完之后,配置g1口,可以直接在g0端口这里int g1,也可以quit退出来退到用户模式下,再进入g1,都可以。配置好R1之后,可以在PC1上ping一下R1,可以ping通的话就说明配置成功了,然后以同样的方法配置R2和R3路由器。都完成之后,我们就开始配置静态路由。

静态路由配置原则 :目的网络号 + 目的网络的子网掩码 + 下一跳的ip地址,这是R1通往3.0 4.0网段的配置,同样R2通往1.0 4.0和R3通往1.0 2.0的也是这样配置。

 

R1上的命令:

system-view
sysname wzgksaR1
​
interface GigabitEthernet 0/0/0
ip address 192.168.1.1 255.255.255.0
​
interface GigabitEthernet 0/0/1
ip address 192.168.2.1 255.255.255.0
quit

R1上的命令

 

配置完成后PC1应该可以Ping通PT1的E0口的地址。

PC1可以Ping通R1的192.168.1.1地址。

PC1可以Ping通R1的192.168.1.1

 

5、给R2路由器命名,为路由器R2的GE0、GE1接口配置IP地址。配置完成后路由器 R1和R2应该可以互相Ping通。要求记录输入的命令和输出(截屏);

 

R2上的命令:

system-view
sysname wzgksaR2
​
interface GigabitEthernet 0/0/0
ip address 192.168.2.2 255.255.255.0
​
interface GigabitEthernet 0/0/1
ip address 192.168.3.1 255.255.255.0
quit

sysname wzgksaR2

 

6、给R3路由器命名,为路由器 R3的 GE0、GE1接口配置 IP地址。

 

R3上的命令:

system-view
sysname wzgksaR3
​
interface GigabitEthernet 0/0/0
ip address 192.168.3.2 255.255.255.0
​
interface GigabitEthernet 0/0/1
ip address 192.168.4.1 255.255.255.0
quit

sysname wzgksaR3

 

配置完成后,直连路由应可相互 Ping通,如PC2应可 Ping通 R3的 GE1口的地址。

PC2可以 Ping通 R3的 192.168.4.1地址;

PC2可以Ping通R2的192.168.4.1地址截图

 

7、为三个路由器分别从左至右配置静态路由。要求记录输入的命令和输出(截屏或文本复制)。配置后可以用disp cur检查配置,或者disp ip route检查路由表。要求记录输入的命令和输出(截屏)。

 

R1上的命令:

ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2

ip route-static 192.168.3.0 255.255.255.0 192.168.2.2 ip route-static 192.168.4.0 255.255.255.0 192.168.2.2

 

R1检查配置:

disp cur

disp cur

 

查看R1i没有任何配置的联通前的路由表命令:

disp ip rout

disp ip rout

配置好之后,在路由器上,我们可以用display ip routing-table命令查看路由表。简写就是dis ip route。然后我跟大家说一下怎么看这个路由表,华为路由表初始化的时候不是空的。cisco是空的,华为ensp模拟器一开始默认就有4个路由条目,都是直连,大家可以看一下上面这个图,是没有任何配置时候的R1的路由表,

Route Flags: R - relay, D - download to fib

R:表示该路由是迭代路由  路由必须有直连的下一跳才能够指导转发,但是路由生成时下一跳可能不是直连的,因此需要计算出一个直连的下一跳和对应的出接口,这个过程就叫做路由迭代。

D:表示该路由下发到FIB表 路由器转发数据包的关键是路由表和FIB表,每个路由器都至少保存着一张路由表和一张FIB(Forwarding Information Base)表。路由器通过路由表选择路由,通过FIB表指导报文进行转发。

Routing Tables: Public

Public: 表示此路由表是公网路由表,如果是私网路由表,则显示私网的名称,如Routing Tables: ABC

Destinations : 4 Routes : 4显示目的网络/主机的总数 显示路由的总数

Destination/Mask  Proto    Pre    Cost    Flags NextHop  Interface

1. Destination表示此路由的目的地址。用来标识IP包的目的地址或目的网络。Mask:表示此目的地址的子网掩码长度。与目的地址一起来标识目的主机或路由器所在的网段的地址。

2. 表示学习此路由的路由协议

3. Pre:表示此路由的路由协议优先级。针对同一目的地,可能存在不同下一跳、出接口等多条路由,这些不同的路由可能是由不同的路由协议发现的,也可以是手工配置的静态路由。优先级高(数值小)者将成为当前的最优路由。

4.Cost:路由开销。当到达同一目的地的多条路由具有相同的路由优先级时,路由开销最小的将成为当前的最优路由。Preference用于不同路由协议间路由优先级的比较,Cost用于同一种路由协议内部不同路由的优先级的比较。

5. 标志位,有好几个不同的值,如果为U:路由可用。一般都有这个标志。

H:目标是一个主机。主机路由:该路由是到一个主机,目的地址是一个完整的主机地址。如果主机匹配,直接走这个路由。

G:该路由是路由到一个网关(如路由器)。该项存在,说明是间接路由,下一跳到一个网关,多次路由后可能到达目标主机,

R:恢复动态路由的路由

D:除了路由表,还有个转发表,真正生效的应该是转发表,D就是下发到了fib表,这条转发路径生效。

6. NextHop:表示此路由的下一跳地址。指明数据转发的下一个设备。

7 .interface:表示此路由的出接口。指明数据将从本地路由器哪个接口转发出去。

127.0.0.0/8          Direct    0     0      D     127.0.0.1    InLoopBack0

(本地的回环网段:127.0.0.0这个网段内所有地址都指向自己机器 127.0.0.1)

127.0.0.1/32         Direct    0    0      D     127.0.0.1    InLoopBack0

(本地的回环地址)

127.255.255.255/32      Direct    0     0      D    127.0.0.1    InLoopBack0

(本地广播路由:当接收到127.255.255.255广播数据包时,直接发给自己 127.0.0.1 )

255.255.255.255/32     Direct    0     0      D   127.0.0.1    InLoopBack0

(绝对广播路由:当接收到255.255.255.255广播数据包时,直接发给自己 127.0.0.1 )

当对AR1路由器的GE2/0/0接口配IP地址后:192.168.2.0/24 ,路由表中会形成直连路由相关条目看下面这幅图

192.168.2.0/24      Direct    0     0    D       192.168.1.254 GigabitEthernet0/0/0

(生成192.168.2.0网段,指明本网段出接口就是192.168.2.254)

192.168.2.1/32    Direct    0     0    D      127.0.0.1      GigabitEthernet0/0/0

(IP地址范围通过掩码32位,锁定IP地址192.168.1.254本身)

192.168.2.255/32      Direct    0     0    D       127.0.0.1      GigabitEthernet0/0/0

(广播路由:当接收到192.168.2.255广播数据包时,直接发给自己 127.0.0.1)

 

R1检查路由表:

disp ip rout

在我们配置完静态路由之后,再 dis ip route 一下,可以看到里面已经增加了两条静态路由,分别是3.0和4.0的,在协议这里已经变成了static,后面的flag变成了RD,R:在路由器上配了个静态路由,所以RD大家就可以理解为是静态路由的意思。

disp ip rout

 

R2上的命令:

ip route-static 192.168.1.0 255.255.255.0 192.168.2.1
ip route-static 192.168.4.0 255.255.255.0 192.168.3.2
disp cur

ip route-static 192.168.1.0 255.255.255.0 192.168.2.1 ip route-static 192.168.4.0 255.255.255.0 192.168.3.2 disp cur

 

R2检测路由表:R2检测路由表

 

R3上的命令:

ip route-static 192.168.1.0 255.255.255.0 192.168.3.1
ip route-static 192.168.2.0 255.255.255.0 192.168.3.1
disp cur

ip route-static 192.168.1.0 255.255.255.0 192.168.3.1 ip route-static 192.168.2.0 255.255.255.0 192.168.3.1 disp cur

 

R3检测路由表:R3检测路由表

 

注意:

如果路由命令输入错误,如输入:

ip route-static 192.168.3.0 255.255.255.0 192.168.2.2

则输入下列命令则可删除刚才的路由:

undo ip route-static 192.168.3.0 255.255.255.0 192.168.2.2

 

8、如配置正确,此时网络收敛,则任何两点之间(含非直连)均可 ping通,验证,如 PC1和PC2可以 ping通。分别使用 ping命令和 traceRT命令来验证, 解释结果显示。要求记录输入的命令和输出(截屏)。

如配置正确,此时网络收敛,则任何两点之间(含非直连)均可 ping通,验证,如 PC1和PC2可以 ping通。分别使用 ping命令和 traceRT命令来验证, 解释结果显示。

大家可以分析一下这个结果,比如PC1 traceroute PC2,显示结果为,PC1到达PC2,共经过4跳,分别经过哪个路由器的哪个接口这样子?可以写到实验报告中。

然后,大家想要删除静态路由配置的话,在系统视图下执行命令"undo ip route-static all",可以一次删除所有静态路由。

要是想删除路由器ip地址配置,也是如“undo ip address 192.168.4.1 255.255.255.0”命令。

这样的话我们静态路由就配置完成了。

 

9、(以下内容为选做)在 PC1上使用抓包工具进行抓包。

首先使用“ arp –d ”命令清空 arp表。

再使用 Ping命令测试到 PC2的连通性(192.168.4.2)。

首先使用“ arp –d ”命令清空 arp表。 再使用 Ping命令测试到 PC2的连通性(192.168.4.2)。

 

分析抓到的 ping命令的 icmp报文。

分析抓到的 ping命令的 icmp报文。

类型8位,值为8;

代码8位,值为0;

结合类型和代码可知该报文为icmp请求报文还是响应报文,属于查询类;

校验和16位,对包括数据在内的icmp数据报进行校验;

标识符16位;

序列号16位,数据32位。

观察可见,icmp请求报文和对应的响应报文具有相同的标识符和序列号,可用于匹配请求和响应报文。

付杰
  • ¥ 999元
  • 市场价:4999元
  • ¥ 499.0元
  • 市场价:499.0元
  • ¥ 45.0元
  • 市场价:45.0元
  • ¥ 98.0元
  • 市场价:298.0元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: