phpmyadmin-错误:配置文件权限错误,不应任何用户都能修改!解决方案

摘要

问:为什么会出现phpmyadmin-错误:配置文件权限错误,不应任何用户都能修改?
答:原因:phpmyadmin目录权限过高,linux系统设置了777访问权限;
解决方案如下:chmod -R 755 phpmyadmin

问:为什么会出现phpmyadmin-错误:配置文件权限错误,不应任何用户都能修改?

答:原因:phpmyadmin目录权限过高,linux系统设置了777访问权限;

phpmyadmin-错误:配置文件权限错误,不应任何用户都能修改!

 

linux(centos)查看文件权限命令如下:

ls -al

linux文件权限777

 

解决方法:

解决这个问题也很简单,只需要给phpmyadmin权限为755就可以了。

chmod -R 755 phpmyadmin

现在你再去访问phpmyadmin,就可以正常访问了!出现以上这个问题,主要是linux服务器居多,windos服务器是很少发生的,因此用windos服务器的人不必担心;

    A+
发布日期:2016年12月16日 19:09:03  所属分类:Linux  Mysql  PHP
最后更新时间:2019-05-02 20:00:45
评分: (1 票;平均数5.00 ;最高评分 5 ;用户总数1;总得分 5;百分比100.00)
付杰
花牛苹果 甘肃天水 李宏恩家自种 1斤 包邮
花牛苹果 甘肃天水 李宏恩家自种 1斤 包邮
  • ¥ 6.8元
  • 市场价:8.8元
PHP运行环境 wamp lamp lnmp 安装 配置 搭建服务
PHP运行环境 wamp lamp lnmp 安装 配置 搭建服务
  • ¥ 9.9元
  • 市场价:49.9元
刷流量、刷人气、刷点击、刷收藏、刷APP关键词服务
刷流量、刷人气、刷点击、刷收藏、刷APP关键词服务
  • ¥ 1.0元
  • 市场价:9.9元
免费SSL证书服务 HTTPS申请 安装 配置 支持通配符*
免费SSL证书服务 HTTPS申请 安装 配置 支持通配符*
  • ¥ 199.9元
  • 市场价:20000元

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:3   其中:访客  2   博主  1

  1. 头像 祝安 4

    755不行直接给777吧,建议大家后删除phpmyadmin,调试用它就行了。

  2. 头像 Michael 0

    不管用,权限已经设置回去了,服务器也也重启了,还是不行

    • 付杰 付杰

      @Michael 不应该啊!你权限设置好了后:再用命令:ls -al 看看phpmyadmin是否设置的是755;以后还解决不了,直接和我临时会话吧!